My OHIO Student Center
Incident Report for Ohio University
Resolved
Enterprise Student Administration (PeopleSoft): Access to My OHIO Student Center has been restored.


Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 3 months ago. Jul 10, 2018 - 12:58 EDT
Investigating
Enterprise Student Administration (PeopleSoft): Technicians are investigating issues with My OHIO Student Center. We will provide updates as they become available.

Affected services:
PeopleSoft
My OHIO Student Center


You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 3 months ago. Jul 10, 2018 - 12:45 EDT
This incident affected: Student Administration (PeopleSoft, etc.) (Student Administration (PeopleSoft)).