Printing through Pharos.
Incident Report for Ohio University
Resolved
Printing through Pharos is now operational.
Posted 15 days ago. Sep 10, 2017 - 18:14 EDT
Identified
The Pharos printing issue has been identified.
Posted 15 days ago. Sep 10, 2017 - 18:07 EDT
Investigating
Printing through Pharos campus wide is experiencing issues at this time.
Posted 15 days ago. Sep 10, 2017 - 17:25 EDT