Internet & phones
Incident Report for Ohio University
Resolved
Phones: Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 13 days ago. Nov 29, 2017 - 11:55 EST
Investigating
Internet & phones: Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:

University telephones

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 13 days ago. Nov 29, 2017 - 11:28 EST
This incident affected: Internet & Phones (Internet & phones on all campuses).