University Telephones
Incident Report for Ohio University
Resolved
University Telephones: Service has been restored.


Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 30 days ago. May 21, 2018 - 04:43 EDT
Identified
University Telephones: Technicians are investigating issues with this service after maintenance was completed at 10pm. Internet service is working. We will provide updates as they become available.

Affected services:
University telephones

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted about 1 month ago. May 20, 2018 - 22:54 EDT