Office 365: Shared mailbox access in Outlook on the web
Incident Report for Ohio University
Resolved
Office 365: Shared mailbox access
Service has been restored. See below for details regarding the cause of this outage:

A recent update, by Microsoft, intended to improve service functionality resulted in unexpected impact to shared mailbox access in Outlook on the web.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 6 months ago. May 03, 2018 - 12:35 EDT
Monitoring
A fix has been implemented. Some users may experience restored service functionality as the fix reaches their environment. Based on current progress, the problem is expected to be resolved within the next twenty-four hours.
Posted 6 months ago. May 01, 2018 - 23:30 EDT
Investigating
Users may be unable to access shared mailboxes within Outlook on the web. Users may receive the following error "Your request can't be completed right now".

Microsoft is investigating this issue and working on a solution. We will provide updates as they become available.

Affected services:
Office 365 (Catmail)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 6 months ago. May 01, 2018 - 19:11 EDT