My Personal Information (myhr.ohio.edu)
Incident Report for Ohio University
Resolved
We have corrected the issue with the icons missing when using off campus connections. This issue has been resolved.
Posted 10 days ago. Dec 07, 2018 - 08:52 EST
Identified
My Personal Information (myhr.ohio.edu)
Navigation icons are not displaying correctly in My Personal Information for off-campus users. This only affects the way the service looks. All features remain available. We have identified a fix and will apply it after normal business hours.

Affected services:
My Personal Information (myhr.ohio.edu)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 11 days ago. Dec 06, 2018 - 10:39 EST
This incident affected: Financial & HR Administration (e-Biz, etc.) (My Personal Information).