Internet & phones - University Terrace Street
Incident Report for Ohio University
Resolved
Internet & phones in specific buildings: Service has been restored.


Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 18 days ago. Jun 27, 2018 - 16:47 EDT
Identified
Internet & phones along University Terrace Street are currently down due to an AEP electric outage. We currently have no known timeline for electric restoration. Updates will be provided as we receive them.


You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 18 days ago. Jun 27, 2018 - 14:06 EDT
This incident affected: Internet & Phones (Internet & phones in specific buildings).