OHIO IDs & Passwords (MyID)
Incident Report for Ohio University
Resolved
OHIO IDs & Passwords (MyID): Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 7 months ago. Apr 15, 2018 - 12:22 EDT
Investigating
OHIO IDs & Passwords (MyID): Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:
OHIO ID activations
OHIO password changes & resets
account.ohio.edu (MyID)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 7 months ago. Apr 15, 2018 - 11:35 EDT
This incident affected: Logins, Passwords & Accounts (OHIO IDs & Passwords).