Concur
Incident Report for Ohio University
Resolved
Concur (travel & expense reporting system): Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 20 days ago. Jun 25, 2018 - 15:43 EDT
Investigating
Concur (travel & expense reporting system): Our vendor has notified us that they are investigating issues regarding inability to log in, complete Travel bookings, and submit Expense reports across multiple Concur Services. Additional teams have been engaged and investigating the cause of the Incident. We will provide updates as they become available.


Affected services:
Concur

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 20 days ago. Jun 25, 2018 - 12:48 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Business Systems Webapps).