Campus VPN
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 15, 2019 - 19:52 EDT
Investigating
The Campus VPN is currently unavailable, technicians are working to restore access.
Posted 6 months ago. Mar 15, 2019 - 19:01 EDT
This incident affected: Internet & Phones (VPN).