OHIO ID & Passwords (MyID)
Incident Report for Ohio University
Resolved
OHIO ID & Passwords (MyID)

Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Nov 26, 2019 - 10:42 EST
Investigating
OHIO ID & Passwords (MyID)

MyID page is currently experiencing issues. This will affect account activation and password resets. Technicians are investigating issues with this service.

We will post updates at least every 2 hours.

Affected services:
OHIO ID activations
OHIO password changes & resets
account.ohio.edu (MyID)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Nov 26, 2019 - 09:05 EST
This incident affected: Accounts, Passwords and Identity (Accounts & Passwords).