OHIO IDs & Passwords (MyID)
Incident Report for Ohio University
Resolved
My OHIO: Service has been restored.
Technicians continue to search for a root cause for the outage.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 6 months ago. Jan 12, 2018 - 11:41 EST
Identified
OHIO IDs & Passwords (MyID): Technicians have identified issues with this service. We will provide updates as they become available.

Affected services:
OHIO ID activations
OHIO password changes & resets
account.ohio.edu (MyID)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 6 months ago. Jan 12, 2018 - 11:24 EST
This incident affected: Web (www.ohio.edu, My OHIO, etc.) (My OHIO).