Potential Catmail Issue, re: Conference Room Scheduling
Incident Report for Ohio University
Resolved
Microsoft released a patch on May 9 that fixed this issue.
Posted May 19, 2017 - 17:07 EDT
Update
Current status, per Microsoft: The deployment of the fix is progressing as expected and is approximately 93 percent complete. As the fix propagates, affected conference rooms will be incrementally repaired.
Posted May 09, 2017 - 16:46 EDT
Update
Current status, per Microsoft: We've completed the process of developing the fix and testing confirmed it as a valid solution for impact remediation. We've started to deploy the fix across the affected infrastructure to remediate impact. As the fix propagates, affected conference rooms will be incrementally repaired.
Posted May 05, 2017 - 11:07 EDT
Monitoring
OIT is sharing this advisory from Microsoft:

Exchange Online Incident EX100146: Conference room scheduling issues

Status: Service degradation

User Impact: Users are unable to book conference rooms from Outlook on the Web and the Outlook client. Other clients connecting to conference room schedules may also be affected. The free/busy status of conference rooms indicate that a room is free, however, users scheduling appointments will receive a decline message from the conference room account, and are unable to schedule a meeting.

Current status: Our investigation determined that a code issue was introduced by a recent update which caused cancelled meetings to remain as a scheduled occurrence for the system. We're gathering log data from the affected infrastructure in order to develop a fix.

Scope of impact: A few customers have reported this issue, and our analysis indicates that this issue could potentially affect any of your users if they are routed through the affected infrastructure.

Start time: Monday, April 24, 2017, at 2:57 PM UTC

Preliminary root cause: A code issue was introduced by a recent update which caused cancelled meetings to remain as a scheduled occurrence for the system.
Posted May 02, 2017 - 14:37 EDT