OHIO Systems Status

Proctortrack Remote Proctoring Service Interruption

Incident Report for Ohio University

Resolved

Proctortrack
Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted Jun 12, 2025 - 17:46 EDT

Investigating

Test takers (students) may encounter difficulties accessing Proctortrack or starting their exams. Instructors may be unable to access dashboards for exam configuration or review.
Posted Jun 12, 2025 - 16:05 EDT
This incident affected: Testing & Surveys (Proctored Exams & Standardized Tests).