Internet & phones in Nelson Dining Hall
Incident Report for Ohio University
Resolved
Internet & phones: Service has been restored.


Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted May 17, 2018 - 14:36 EDT
Investigating
Internet & phones in specific buildings: Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:
Nelson Dining Hall
Wired Internet
University telephones
Posted May 17, 2018 - 13:22 EDT
This incident affected: Internet & Phones (Internet & phones on all campuses, Internet & phones in specific buildings).