OHIO Systems Status

Peoplesoft Issue

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Apr 26, 2025 - 14:32 EDT

Investigating

Academic Apps (Course Offerings, Faculty & Advising Center, and enrollment) are currently not operational. We are investigating this issue and will post updates as they become available.
Posted Apr 26, 2025 - 14:17 EDT
This incident affected: Student Administration (PeopleSoft, etc.) (Academic Apps (Course Offerings, Faculty & Advising Center, etc.)).