OHIO Systems Status

Chillicothe Campus Network Outage

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Sep 29, 2024 - 18:20 EDT

Investigating

We are currently investigating this issue.
Posted Sep 27, 2024 - 16:19 EDT
This incident affected: Internet & Phones (Regional campus Internet & phones).