OHIO Systems Status

Go OHIO

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 11:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 11:08 EDT

Investigating

Modo (the vendor for Go OHIO) has reported degraded performance and we've confirmed that go.ohio.edu and the mobile app may be inaccessible for users. Both mobile and web clients appear to be impacted.

We are currently investigating, as is the vendor.
Posted Aug 24, 2026 - 10:24 EDT
This incident affected: Additional IT Services (Go OHIO Mobile App).