OHIO Systems Status

LastPass Email Server Down

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 15:16 EDT

Identified

LastPass
We have been informed that LastPass is having an issue with its email server. LastPass's email service is down so anyone trying to reauthenticate with Lastpass will have issues

Affected services:
LastPass

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Oct 01, 2025 - 11:26 EDT
This incident affected: Additional IT Services (Other IT Services).