OHIO Systems Status

My Personal Information (myhr.ohio.edu)

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 14:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2025 - 10:57 EDT

Investigating

My Personal Information (myhr.ohio.edu)
Currently investigating an issue with myhr.ohio.edu not allowing users to log in.

Affected services:
My Personal Information (myhr.ohio.edu)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Sep 08, 2025 - 10:11 EDT
This incident affected: Financial & HR Systems (My Personal Information (MPI)).