OHIO Systems Status

PaymentWorks Outage

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 11:09 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 17, 2025 - 11:09 EDT

Investigating

PaymentWorks
Users are seeing a blank page when logged into PaymentWorks. Technicians are investigating issues with this service.
We will post updates at least every [insert time] hours.

Affected services:
PaymentWorks

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Sep 17, 2025 - 08:48 EDT
This incident affected: Additional IT Services (Other IT Services).