OHIO Systems Status

VitalSource Bookshelf Online

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 14:42 EDT

Investigating

VitalSource Bookshelf Online

Some Users may be having problems logging into their Bookshelf Accounts. There is currently no workaround, the vendor is investigating the issue.


Affected Service
VitalSource Bookshelf Online

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Aug 20, 2026 - 10:39 EDT
This incident affected: Teaching & Learning Tools (VitalSource Digital Course Materials).