OHIO Systems Status

Survey Tools (Qualtrics)

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 18:36 EST

Investigating

Survey Tools (Qualtrics)
The vendor is investigating distribution delays, Qualtrics Email Distributions, in our Eastern US Region.End users may notice distributions with status "In Progress" for an extended period of time.
We will post updates as they become available

Affected services:
Online surveys via qualtrics.ohio.edu

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Feb 18, 2025 - 15:57 EST
This incident affected: Testing & Surveys (Surveys (Qualtrics)).