The issue has been identified and a fix is being implemented.
Posted Feb 10, 2026 - 16:56 EST
Update
The following buildings are still down at this time: Bird Arena Irvine Hall Ryors Hall Sargent Hall Peden Stadium All others appear to have recovered.
Posted Feb 10, 2026 - 16:16 EST
Investigating
Internet & Phones in West Green/Athletics Degraded wireless coverage as UPS backups fail and/or emergency generator availability. Technicians are investigating issues with this service.
Affected Buildings: West Green/Athletics
Affected Services: Wired Internet WiFi University telephones
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Feb 10, 2026 - 12:27 EST
This incident affected: Network & Phone Services (Building-Specific Internet & Phones).