Internet & Phones
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 16:52 EST
Investigating
Internet

Technicians are investigating issues with internet service. Users may experience slow internet service due to a large volume of traffic.

We will post updates as they become available.

Affected services:
Wired Internet
WiFi


You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Feb 20, 2020 - 12:08 EST
This incident affected: Internet & Phones (Internet & phones on all campuses).