OHIO Systems Status

OneDrive

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 11:12 EST

Monitoring

Microsoft reports they have implemented a fix for this incident.
We will monitor inbound tickets from the weekend through today to determine whether the issue persists.
Posted Feb 24, 2025 - 11:13 EST

Investigating

OneDrive
Technicians are investigating issues with this service. Some users are reporting receiving multiple email notifications of OneDrive files being shared with them. Sharing is working as intended.

Affected services:
Office 365 cloud storage
onedrive.ohio.edu

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Feb 21, 2025 - 11:18 EST
This incident affected: File Storage & Sharing (OneDrive).