Time & Attendance (WorkForce)
Incident Report for Ohio University
Resolved
Time & Attendance (WorkForce): Service has been restored.
Technicians continue to search for a root cause for the outage.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 7 days ago. Sep 16, 2018 - 12:11 EDT
Investigating
Time & Attendance (WorkForce): Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:
WorkForce Time & Attendance

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 7 days ago. Sep 16, 2018 - 12:05 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Time & Attendance (WorkForce)).