Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 23, 2025 - 02:00 EDT
Scheduled
Cleveland Campus Internet & Phones Wednesday, July 23, 2025 - 2:00 AM - 4:00 AM
During the maintenance window (beginning at 02:00 AM), customers at Cleveland Campus will experience an outage for:
Wired network connectivity
Wi-Fi access
VoIP phone service
Expected downtime per site is approximately 15 - 20 minutes per reboot. Each building will have two reboots.
Affected Campuses and Services: Cleveland Wired Internet WiFi University telephones
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 10, 2025 - 11:52 EDT
This scheduled maintenance affected: Network & Phone Services (Regional Campus Internet & Phones).