Concur
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted 5 months ago. May 29, 2018 - 16:09 EDT
Identified
Concur (travel & expense reporting system): Our vendor has notified us that they are investigating issues with this service. We will provide updates as they become available.


Affected services:
Concur

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 5 months ago. May 29, 2018 - 11:30 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Business Systems Apps).