OHIO Systems Status

Turnitin within Canvas

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted May 07, 2026 - 13:33 EDT

Investigating

Turnitin within Canvas - Turnitin Feedback Studio is currently experiencing an unexpected service incident.


You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted May 07, 2026 - 11:58 EDT
This incident affected: Teaching & Learning Tools (Canvas (LMS)).