OHIO Systems Status

Canvas (Learning Management System)

Incident Report for Ohio University

Resolved

Vendor has confirmed this is resolved.
Posted Aug 31, 2026 - 21:50 EDT

Investigating

Canvas (Learning Management System)

Some users are getting a "Website is under heavy Load" message indicating the site request has timed out. Users who are already logged in may notice pages are loading slowly.


Affected Service
Canvas (Learning Management System)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Aug 31, 2026 - 14:17 EDT
This incident affected: Teaching & Learning Tools (Canvas (LMS)).