University telephones
Incident Report for Ohio University
Resolved
University telephones: Service has been restored. Maintenance work this morning caused the impact to the phones.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 7 months ago. Mar 03, 2019 - 12:30 EST
Investigating
University telephones: Technicians are investigating issues with this service. Outbound calls from the university may not be completing for some users. We will provide updates as they become available.

Affected services:
VoIP telephones & related services

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 7 months ago. Mar 03, 2019 - 11:07 EST
This incident affected: Internet & Phones (Internet & phones on all campuses, Telephone).