Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2026 - 12:00 EDT
Scheduled
Internet & Phones in Specific Buildings Friday, July 31 - August 2nd 12:00 PM July 31 - Mid-Afternoon August 2nd
Zanesville Campus will have a planned outage starting Friday Jul 31 at around Noon until Sunday August 2 mid afternoon while contractors performed planned maintenance.
Affected Buildings: Elson Herold Littick
Affected Services: Power in impacted buildings. Wired Internet WiFi University telephones
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 31, 2026 - 08:46 EDT
This scheduled maintenance affects: Network & Phone Services (Regional Campus Internet & Phones, Building-Specific Internet & Phones).