OHIO Systems Status

Time & Attendance (WorkForce)

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 10:58 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 11, 2025 - 10:58 EDT

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 08:57 EDT

Investigating

Time & Attendance (WorkForce)
workforce.ohio.edu is down for payroll processing and the application will be back up later this morning.

Affected services:
WorkForce Time & Attendance

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Sep 11, 2025 - 08:55 EDT
This incident affected: Financial & HR Systems (WorkForce Time & Attendance).