OHIO Systems Status

TeamDynamix (TDX)

Incident Report for Ohio University

Resolved

Services are restored and this incident has been resolved
Posted Apr 22, 2025 - 17:40 EDT

Investigating

TeamDynamix (TDX)
Services are rendering as not available or degraded if available.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Apr 22, 2025 - 15:30 EDT
This incident affected: Other (Team Dynamix (TD Next)).