Regional Campus Internet & Phones - Cleveland Campus
Incident Report for Ohio University
Resolved
Power was restored appx 8pm 12/1 and service was restored.
Posted Dec 02, 2020 - 09:41 EST
Investigating
Regional Campus Internet & Phones
Technicians are investigating issues with this service. Internet and Telephone services are down for the Cleveland Campus due to a power outage.

We will post updates as we receive them.

Affected Campuses and Services:
Cleveland Campus
Wired Internet
WiFi
University telephones

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Dec 01, 2020 - 16:34 EST
This incident affected: Internet & Phones (Regional campus Internet & phones).