OHIO Systems Status

Concur (Travel & Expense Reporting System)

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 16:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2026 - 16:21 EDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 10:28 EDT

Investigating

Concur (Travel & Expense Reporting System)
Concur has identified a service degradation that is currently affecting system performance. We have also received reports from users experiencing slowness and disruptions while performing their daily activities in Concur.

Affected services:
Concur

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Mar 30, 2026 - 10:24 EDT
This incident affected: Financial & HR Systems (Concur Travel & Expense).