My Personal Information (myhr.ohio.edu) and Workforce
Incident Report for Ohio University
Resolved
My Personal Information (myhr.ohio.edu) and Workforce: Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 5 months ago. Apr 15, 2018 - 10:39 EDT
Investigating
My Personal Information (myhr.ohio.edu)
Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:
My Personal Information
myhr.ohio.edu
Workforce
workforce.ohio.edu

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 5 months ago. Apr 15, 2018 - 10:35 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Financial & HR Administration (Oracle e-Business Suite and related apps), My Personal Information, Time & Attendance (WorkForce), Business Systems Apps).