University telephones
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 31, 2018 - 22:47 EDT
Investigating
Cleveland Campus University telephones: Users are currently unable to make calls out from campus. Technicians are investigating issues with this service. We will provide updates as they become available.

Affected services:
VoIP telephones & related services

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 18 days ago. Oct 31, 2018 - 16:55 EDT
This incident affected: Internet & Phones (University telephones).