OHIO Systems Status

University Telephones

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 21:54 EDT

Investigating

University Telephones

Technicians are investigating issues that may impact Verizon customers.

We will post updates at least every 2 hours.

Affected services:
VoIP telephones & related services

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Mar 14, 2026 - 19:26 EDT
This incident affected: Network & Phone Services (VoIP Telephone Service).