This issue is still ongoing. Jaggaer Support has classified it as an emergency and is actively working on a resolution. At this time we do not have an estimated timeline for when the issue will be resolved.
Posted Feb 27, 2026 - 14:25 EST
Investigating
BobcatBUY (Procurement: Requisitioning, Purchasing System) The Payment Request Form in BobcatBUY is experiencing an application error. Users can successfully create and submit new Payment Request forms, but attempting to view submitted forms triggers an application error. Jaggaer support is actively investigating and will provide an update once the issue is resolved.
Affected services: BobcatBUY
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Feb 27, 2026 - 08:46 EST
This incident affects: Financial & HR Systems (BobcatBUY Procurement).