External services that were being reported as unavailable or unable to resolve appear to be recovering. We will continue to monitor this issue.
Posted Mar 06, 2026 - 09:24 EST
Investigating
Impacted: Ohio University Network Users
We are currently experiencing an issue causing intermittent unavailability of our external website and certain online services. Some customers may notice:
Pages that fail to load or load slowly Difficulty accessing account‑related features Interrupted or delayed online transactions Occasional error messages when navigating the site
Our IT teams are actively investigating the cause and working to restore stable service as quickly as possible. We understand how important consistent access to our website and services is to your experience, and we apologize for the inconvenience this may cause. We will continue to provide updates as more information becomes available or once the issue is fully resolved.
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Mar 06, 2026 - 09:08 EST
This incident affected: Network & Phone Services (Campus Internet & Phones, Virtual Private Network (VPN), VoIP Telephone Service).