OHIO Systems Status

Wired Network Outage - Cleveland and Dublin

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 07:49 EDT

Investigating

Wired Network Outage - Cleveland and Dublin
Technicians are investigating issues with this service. Use of wired network services are down.

Affected Buildings:
Cleveland and Dublin campus

Affected Services:
Wired Internet

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Aug 25, 2025 - 12:58 EDT
This incident affected: Network & Phone Services (Regional Campus Internet & Phones).