Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 22:00 EDT
Scheduled
Internet & Phones in Specific Buildings Wednesday May 20th - Thursday May 21st 10:00 PM - 6:00 AM
There will be a network outage expected to last less than 30 minutes, impacting voice, video, & data for the affected sites.
Affected Buildings: OHIO Airport Albany OHIO Lancaster Campus OHIO West State Street Complex OHIO Zanesville Campus OUHCOM Woodland Center Inc. Meigs County Office
Affected Services: Wired Internet WiFi University telephones
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted May 18, 2026 - 09:10 EDT
This scheduled maintenance affected: Network & Phone Services (Building-Specific Internet & Phones).