Regional Campus Internet & Phones
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 10:20 EDT
Investigating
Regional Campus Internet & Phones
We are having very slow network speeds in Cleveland after a building power outage. Wired and Wi-fi are affected.


Affected Buildings:
Cleveland

Affected Services:
Wired Internet
WiFi

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 16, 2024 - 08:57 EDT
This incident affected: Internet & Phones (Regional campus Internet & phones).