OHIO Systems Status

OHIO ID & Passwords (MyID)

Incident Report for Ohio University

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 14:46 EDT

Investigating

OHIO ID & Passwords (MyID)
Technicians are investigating issues with this service. Users will need to reset their password via the Microsoft site instead by logging onto https://mysignins.microsoft.com/ and clicking Password.



Affected services:
OHIO password changes & resets
account.ohio.edu (MyID)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Apr 08, 2025 - 14:30 EDT
This incident affects: Accounts, Passwords and Identity (Accounts & Passwords).