OHIO ID & Passwords (MyID)
Incident Report for Ohio University
Resolved
OHIO ID & Passwords (MyID)
Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Nov 16, 2020 - 20:22 EST
Investigating
OHIO ID & Passwords (MyID)
Technicians are investigating issues with this service. Services will be unavailable from 7:45 pm to 8:15 pm.

Affected services:
OHIO ID activations

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Nov 16, 2020 - 19:32 EST
This incident affected: Accounts, Passwords and Identity (Accounts & Passwords).