OHIO Systems Status

TeamDynamix (TDX)

Incident Report for Ohio University

Monitoring

The vendor has identified and addressed the root cause of the issue and will continue to monitor.
Posted Jun 02, 2025 - 13:27 EDT

Investigating

TeamDynamix (TDX)
Technicians are not able to load TDX to create or update tickets.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jun 02, 2025 - 09:03 EDT
This incident affects: Other (Team Dynamix (TD Next)).