print.ohio.edu
Incident Report for Ohio University
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 13:24 EST
Update
We continue to experience degraded performance and will provide an update as soon as one is available.

We understand that printing is a requirement for many users on campus, and we are prepared to help users with a workaround until Microsoft provides a fix for this issue. For help reconnecting your Windows device to your printer, please contact the IT Service Desk by creating a ticket at help.ohio.edu or calling (740) 593-1222.
Posted Nov 09, 2021 - 17:05 EST
Update
Degraded Service printing on Ohio University campuses. Degraded service was caused by a security patch issued by Microsoft within the past two weeks. Although this issue is not fully resolved and a solution has not been provided by Microsoft, technicians have provided a manual workaround and as of today a workaround that allows users to install and use printers as normal. 

This is a workaround and will appear as a degraded service until the issue is fully resolved by Microsoft. We understand that printing is a requirement for many users on campus and we are prepared to help users with printing issues.

For help to reconnect your Windows device to your printer, please contact the IT Service Desk by creating a ticket at help.ohio.edu or calling (740) 593-1222. 

For technical information on the cause of this issue, please see the Known Issues sections of the October 12, 2021 release notes for Windows 10 and Windows 11. 

We will provide updates as we receive them from Microsoft on this issue.
Posted Nov 05, 2021 - 16:35 EDT
Update
There is a widespread outage preventing Windows users from sending print jobs to printers across Ohio University campuses. This outage is caused by a security patch issued by Microsoft within the past two weeks.

We understand that printing is a requirement for many users on campus, and we are prepared to help users with a workaround until Microsoft provides a fix for this issue. For help reconnecting your Windows device to your printer, please contact the IT Service Desk by creating a ticket at help.ohio.edu or calling (740) 593-1222.

For technical information on the cause of this issue, please see the Known Issues sections of the October 12, 2021 release notes for Windows 10 and Windows 11.

We will provide updates as we receive them from Microsoft on this issue.
Posted Nov 02, 2021 - 08:15 EDT
Identified
There is a widespread outage preventing Windows users from sending print jobs to printers across Ohio University campuses. This outage is caused by a security patch issued by Microsoft within the past two weeks.

We understand that printing is a requirement for many users on campus, and we are prepared to help users with a workaround until Microsoft provides a fix for this issue. For help reconnecting your Windows device to your printer, please contact the IT Service Desk by creating a ticket at help.ohio.edu or calling (740) 593-1222.

For technical information on the cause of this issue, please see the Known Issues sections of the October 12, 2021 release notes for Windows 10 and Windows 11.
Posted Nov 01, 2021 - 16:23 EDT
Update
We are continuing to investigate this issue. We will update you in 24 hours.
Posted Nov 01, 2021 - 11:34 EDT
Investigating
Print.ohio.edu

Technicians are investigating issues with this service. Some of the jobs being sent to print.ohio.edu jobs are not printing. If you are trying to install a new printer that is not working at this time.

Affected services:
print.ohio.edu

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Nov 01, 2021 - 09:29 EDT
This incident affected: Computer & Device Support (Guest Printing, Student Printing, Managed Printing for Departments) and Other (Other).