OHIO Systems Status

Credit Card Processing Outage

Incident Report for Ohio University

Resolved

Culinary and other departments are reporting that this issue is resolved.
Posted Aug 15, 2025 - 13:36 EDT

Investigating

Credit Card Processing Outage

The university’s credit card processing vendor is currently experiencing a service outage/degradation. As a result, some campus services may be temporarily unable to accept credit card payments.

We apologize for the inconvenience and appreciate your patience as the vendor works to resolve the issue. We will provide updates as more information becomes available.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Aug 15, 2025 - 12:48 EDT
This incident affected: Additional IT Services (Other IT Services).